[linux-audio-user] Re: Rosegarden instrument selection

Mark Constable markc at renta.net
Sun Feb 13 10:04:13 EST 2005

tim hall wrote:
>>Second, the "midi connection manager" is not working as described.  I
>>can create new devices in both play and record but I cannot connect them
>>to the soundcard connection to my keyboard.  The choice is in the
>>dropdown, but when I click on it the "No Connection" item remains selected.

> Rosegarden doesn't actually contain any instruments as such. If your version 
> is compiled with DSSI support, you will be able to use synth plugins. Else 
> you need to connect to a softsynth via JACK. I generally launch QJackCtl and 
> QSynth (fluidsynth gui) and then Rosegarden.

I've had this same problem with every version of Rosegarden
I've tried for the last year. I've got an SBlive so I load
up 8mbgmsfx.sf2 with asfxload then start rosegarden, import
a mid file and then goto Composition->Studio->Manage MIDI
Devices, click New and the drop down to the left shows a
variety of ALSA ports so I select "65:0 Emu10K1 Port 0 (write)"
and the dropdown always goes back to "No connection"...
no matter what variation I try. 

pmidi -p 65:0 some.mid works. muse(seq) works with this
combo and also with timidity -iA.

Just now I loaded up qjackctl and qsynth with the same sf2
and indeed rosegarden shows "129:0 Synth input port (32135:0)"
but the dropdown always reverts to "No connection".

I hope I'm doing something really dumb but I've tried at
least a dozen times over the last 12 months with various
versions of rosegarden, kernels and alsa and everything else
looks like it will work except I can't select any instruments.
The only thing is I am running an AMD64 box... but like I say,
most other software that I have tried does work.


More information about the Linux-audio-user mailing list