[linux-audio-user] jamin 0.9.0 seg fault

Matt Henley nwmatt at gmail.com
Fri Feb 18 15:08:20 EST 2005

i use realtime-lsm which seems to work except for amSynth and

amSynth says:

GLib-WARNING **: getpwuid_r(): failed due to: No such user 1000.
terminate called after throwing an instance of 'std::bad_alloc'
 what():  St9bad_alloc
/usr/bin/amSynth: line 75: 15640 Aborted                 

and SpiralSynthModular only wants to run with the realtime switch if i
am logged in as root.

On Fri, 18 Feb 2005 20:50:58 +0100, Arnold Krille
<arnold at roederberg.dyndns.org> wrote:
> On Friday 18 February 2005 21:32, Dubphil wrote:
> > On Fri, Feb 18, 2005 at 07:58:08PM +0100, Bengt Gördén wrote:
> > > I use gentoo and it shouldn't install 2 version side by
> > > side. I run updatedb every night and I can't see any extra jackd.
> > Hey hey that's sounds something to me as i'm also on gentoo,
> > I have all the stuff from the portage jackd libs...etc
> > I have the same problem with the portage jamin, so I try to compile it
> > from another source and it is the same result.
> > Is this a gentoo issue only ?
> My Jamin 0.9.0 works well. Gentoo system with ACCEPT_KEYWORDS="~x86"...
> jack is version 0.99.0-r1.
> Do you use some kind of realtime-mechanism? (suid, realtime-lsm, etc...)
> Arnold
> --
> There is a theory which states that if ever anyone discovers exactly what the
> Universe is for and why it is here, it will instantly disappear and be
> replaced by something even more bizarre and inexplicable.
> There is another theory which states that this has already happened.
> -- Douglas Adams, The Restaurant at the End of the Universe

More information about the Linux-audio-user mailing list