[linux-audio-user] unable to use qsynth

Dave Phillips dlphillips at woh.rr.com
Sat May 21 22:54:47 EDT 2005

Noah Roberts wrote:

>I am trying to use qsynth to play midi files through jack.  I have
>tried 3 different sound fonts.  2 make no sounds and the GM font just
>crashes with output 'Killed'.  fluidsynth does the same when using
>that font.  When I play the midi with pmidi -p 129:0 file.mid I see
>green lights flash and such, but no sound comes out.  I turned up gain
>but nothing happens.  Using Qjackctl I see that the connections are
>right, it should be making noise.  Pmidi seems to be ok with it... 
>But nothing comes out.  I have tried 3 different fonts and 2 different
>files having totally different content (one heavy metal the other
>piano music).  I don't know what to try next.
Noah, how are you starting qsynth ? Specifically, what fonts have you 
tried ? I think fluidsynth has some troubles with large soundfonts, at 
least I've been unable to use qsynth with the Fluid_R3 font. Works fine 
with Creative's 8mbgmsfx.sf2 though.

Youve connected qsynth's audio output to alsa_pcm in the Qjackctl audio 
connections panel ? Volume is up on the mixer ?

Please let me know what fonts you've tried. Details help. :)



More information about the Linux-audio-user mailing list