[linux-audio-user] Terratec Aureon 7.1 Universe

Brian Meidell mailinglists at mindflow.dk
Sun May 29 15:28:23 EDT 2005


Since I kept coming across the linux audio user discussions in my
continuing quest to make my soundcard work under linux, I thought I'd
join and start bugging you with questions.

I have the soundcard mentioned in subj.

I have a set of cambridge soundworks hooked up to the coax digital out
and a set of headphones to the headphones output.

It took me a while, but I got sound playing out of the coax digital
output. I did this by fiddling with a .asoundrc and alsamixer.
Finally I found a combo that worked. I had to lock my internal mixer
rate to 32000 and use that as the rate in .asoundrc.
I never tried setting the rate that low, since the rate I normally see
in conjunction with audio equipment and digital connections is 44100 or

I then tried getting sound of the analog outputs, and that took me ages.
I have no idea what I did, since it was nothing I hadn't done several
times previously, but suddenly I got sound out of the analog outputs.
I could use any matched set of alsamixer internal clock rate and
.asoundrc rate up to 192000.
I did a little victory dance.

Then I hit the volume button on my keyboard, which changes the volume
with kmix. The sound disappeared.
I could get sound out of the digital coax again (changing the default
device in .asoundrc), but no matter what I did, I couldn't get analog
sound back.

I tried rebooting, turning off the machine, etc. Nothing helped.
Then suddenly after a couple of days, I tried switching back to analog
output and it worked for no apparent reason. I thought I knew what I did
right this time (messing with the multi track rate reset button in
alsamixer - I still have no clue what this is for) and bravely hit the
volume button to see if I could break the sound again.

I could. And I couldn't get it back until a few days later when it
mysteriously reappeared. After the next reboot it was gone again.

Now I have my analogue sound and I am not keen to launch kmix no time
soon. Or to reboot.

I still have no idea what I am doing wrong, but I am very keen to see
the .asoundrc and alsamixer settings of someone with a Aureon 7.1
Universe card.

Another thing I'd like to do is to make alsa play on the digital and
analog outputs at the same time, instead of having to choose between two
different pcm devices in .asoundrc.

I have RTFMed as well as I could, exerimented and googled a fair amount.
I even tried modifying envy24control to work with ICE1724 cards, but
quickly got stuck.

Any clues, pointer or help is greatly appreciated.

Brian Meidell Andersen

More information about the Linux-audio-user mailing list