[linux-audio-user] kernel- only slightly better...

thewade pdman at aproximation.org
Thu Nov 17 23:18:27 EST 2005

 > On Thu, 2005-11-17 at 18:03 -0800, thewade wrote:
 > >/ The best I can do with jack without out more then the 13 initial XRUNS
/> >/ is:
/> >/ /usr/local/bin/jackd -R -P70 -u -dalsa -dhw:0 -r48000 -p256 -n2 -m -H
/> >/ -M
/> >/ ...though qjackctl says
/> >/ cannot use real-time scheduling (FIFO at priority 69) [for thread
/> >/ -1211757648, from thread -1211757648] (1: Operation not permitted)
/> >/ cannot lock down memory for RT thread (Cannot allocate memory)
/> >/ the qjackctl statistics window says realtime is enabled.
/> >/
 > Your realtime LSM is somehow not working right, as JACK is unable to run
 > in realtime mode.
Odd. When I run jack from the command line I get none of these error 
messages, but then again I am not using any verbosity related flags either.

 > Make sure you are really in group 500 (run "groups" and "grep
 > 500 /etc/group").
'id -G' returns 500, and 'cat /etc/group | grep pdman' returns 
I seem to recal last time I tried to do the LSM thing I had to patch 
PAM: could this have anything to do with it? I have selinux disabled also.

 > Check "dmesg | grep -i realtime" to make sure that
 > the realtime module is being loaded with the correct options.
Realtime LSM initialized (all groups, mlock=1)

 > Also try
 > unloading realtime LSM and forcibly reloading it from the command line:
 > # rmmod realtime
 > # modprobe realtime gid=500
done. Now 'dmesg | grep -i realtime' says "Realtime LSM initialized 
(group 500, mlock=1)"
No better performance though.

Thanks for the help!

More information about the Linux-audio-user mailing list