[linux-audio-user] jackd: too many servers already active

Ken Schutte kschutte at csail.mit.edu
Fri Sep 30 21:48:36 EDT 2005

Paul Davis wrote:
>>I did find two files that I tried deleting:
> neither one is related.

Okay.  I guess somehow on more reboot did it then...

>>Initialy I was getting the same error, but after rebooting now it works!
>>Well, I shouldn't say it's now working... now I'm getting:
>>   required capabilities not available
>>   capabilities: = cap_ipc_lock,cap_sys_nice,cap_sys_resource+e
>>within the qjackctl messages on start.
>>But, I guess this is unrelated, so I'll have to look into this now...
> it is unrelated. what kernel version are you running and what jack
> startup command are you using?

jackd version 0.99.36

I've been trying a bunch of ways to start jack from command line and
qjackctl.  If I simply do "jackstart -d alsa", I get:

jackstart: cannot get realtime capabilities, current capabilities are:
            =ep cap_setpcap-ep
     probably running under a kernel with capabilities disabled,
     a suitable kernel would have printed something like "=eip"

back from read, ret = 1 errno == Success
jackstart: could not give capabilities: Operation not permitted
jackd 0.99.36
Copyright 2001-2003 Paul Davis and others.
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

JACK compiled with System V SHM support.
loading driver ..
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames, buffer = 2 periods
Couldn't open hw:0 for 32bit samples trying 24bit instead
Couldn't open hw:0 for 24bit samples trying 16bit instead
nperiods = 2 for capture
nperiods = 2 for playback

I've been trying some different input and output devices in qjackctl, 
but nothing seems to work.  Things used to work with all the defaults, 
and I'm not sure what I changed, so I'm not sure what happened...

More information about the Linux-audio-user mailing list