[linux-audio-user] Problem possibly RT related?

Noah Roberts roberts.noah at gmail.com
Sun Jan 1 19:19:39 EST 2006

On 1/1/06, Lee Revell <rlrevell at joe-job.com> wrote:

> Maybe you can try the beta driver:
> http://rt2x00.serialmonkey.com/wiki/index.php/Rt2x00_beta

Yeah, that one has other problems and still won't connect to nothing. 
It also causes serious stability problems when you send certain
commands with iwlist.  Breaks something so inherent that all further
network config commands crash, ie ifconfig, iwconfig, etc...

I actually thought I was running that one earlier but I was wrong, I
had inadvertently left the old one in and was loading it.

I'm just going to take the damn card back.  I'm not in the mood for
trying to get something like this to work right.  I'm just hoping I
can find ANYTHING that will work in Linux at this point...this is the
second card I've tried.

Now, on a different note: After trying with the new kernel and such I
tried suspend to disk again and it still crashes with a mention about
PREEMPT.  I wrote down some details, I am hoping it is enough but if
not I /can/ recreate and write down the whole damn oops output.  Here
is what I grabbed:

First, right before the crash this message was output:

Warning: bash /8051/ changed soft IRQ flags

Then the crash:

Call trace (actuall addresses ommited):
  swsusp_suspend + 6

Crash is about a null pointer derefenced at 00..0038

RIP: global_eventsource_suspend+8

PGD 35bff067 PUP 36710067
Oops: 0000 [1] PREEMPT <- the only place preempt is actually mentioned.

Loaded mods: 8139too mii usbhid ohci_hcd psmouse usbcore

Pid: 8051, comm: bash Not Tainted 2.6.15-rc7-rt1 #1

Lots of register values...again, I can easily recreate this bug so I
decided to see if this was enough.  This an RT issue or a suspend

More information about the Linux-audio-user mailing list