[linux-audio-user] RT and Jack problems

Mark Knecht markknecht at gmail.com
Mon Jun 19 15:59:23 EDT 2006

On 6/19/06, Hiram Abiff <domain.admin at online.ie> wrote:
> Konichiwa!!
> This has been bothering me for some time. I cannot, for the life of me,
> run the muse sequencer with full real time (RT) capabilities.
> I use Slackware 10.2 and a kernel that has RT capabilities
> compiled in.
> I start qjackctl which, in turn, starts the jack daemon (jackd) with
> RT enabled, which is indicated in qjackctl GUI (letters RT showing!!).
> But, then when I fire up muse I get this:
> Trying RTC timer...
> got timer = 14
> showMarker 0
> tickValues(0x41d3a21) not found(1)
> tickValues(0x41d3a21) not found(1)
> 3set realtime scheduler: Operation not permitted
> watchdog process 22391 _NOT_ running SCHED_FIFO
> JACK ERROR: cannot lock down memory for RT thread (Cannot allocate memory)
> JACK ERROR: cannot use real-time scheduling (FIFO at priority 9) [for
> thread -1284142160, from thread -1284142160] (1: Operation not
> permitted)
> error set_schedparam 2:: Operation not permitted
> set realtime scheduler: Operation not permitted
> midi thread 22391 _NOT_ running SCHED_FIFO
> JACK thread not running SCHED_FIFO, try to set...
> set realtime scheduler: Operation not permitted
> JACK still not running FIFO !?!
> ======reliable RT operation not possible!!======
> I tried setting the permissions on the /dev/rtc device so that
> regular users can have access, it didn't help. What could be the
> issue here, I probably misconfigured or am missing something.
> Please help.
> Hiram

   There are a few things to discover:

1) Are you running Jack as root or a user?

- First, try running Jack as root and see if these problems go away.

2) Assuming you run as root without problems then the issue here is
probably one of permissions. However it is not /dev/rtc that needs to
be changed. Infact, nothing in /dev should be changed for this to
work. You either need to install the realtime-lsm package, create a
realtime group, add yourself to that group, and then load the realtime
module telling it to grant realtime permissions to that group. For
this to work you need a kernel with Linux Capabilities enabled in the
security section of the .config file.

Alternatively there is a PAM based solution to this that is newer but
I haven't used it.

Hope this helps,

More information about the Linux-audio-user mailing list