[linux-audio-user] RT and Jack problems

Hiram Abiff domain.admin at online.ie
Wed Jun 21 16:30:47 EDT 2006

Quoting Mark Knecht <markknecht at gmail.com>:

> Hiram,
>   There are a few things to discover:
> 1) Are you running Jack as root or a user?
> - First, try running Jack as root and see if these problems go away.
Gruß Dich, Mark
I tried running it as root, works great.

> 2) Assuming you run as root without problems then the issue here is
> probably one of permissions. However it is not /dev/rtc that needs to
> be changed. Infact, nothing in /dev should be changed for this to
> work. You either need to install the realtime-lsm package, create a
> realtime group, add yourself to that group, and then load the realtime
> module telling it to grant realtime permissions to that group. For
> this to work you need a kernel with Linux Capabilities enabled in the
> security section of the .config file.

I recompiled my kernel with the required module, I created a realtime
group, added my user to it and loaded the module. lsmod reports
it's loaded. However, I still get the same error messages when running
muse. :(

I also noticed that when running qsampler with ALSA output, not JACK,
I get this in the messages window:

22:30:07.751 Channel 0 Some channel settings could not be set. Sorry.
Thread: WARNING, can't assign realtime scheduling to thread!: Operation 
not permitted
Thread: WARNING, can't mlockall() memory!: Cannot allocate memory

> Alternatively there is a PAM based solution to this that is newer but
> I haven't used it.
> Hope this helps,
> Mark

It does.



More information about the Linux-audio-user mailing list