[LAU] [ANN] TapStart 0.1 released

Dragan Noveski perodog at gmx.net
Mon Sep 10 17:08:40 EDT 2007

Arnold Krille wrote:
> Hi all,
> following a basic rule for open source project "publish early and often" I 
> release the very first (but quite feature-rich) version of TapStart to the 
> public.
> TapStart is a basic tempo-measurement where you tap some beats and get the 
> (averaged) tempo displayed. But there is more to it:
>  - TapStart also updates the jack-tempo (if a running jack was found during 
> startup) and can even start the jack transport after a defined number of 
> taps. This is implemented for using this thing in jam-sessions to get a 
> click/drum-computer to play in a tempo not known before.
>  - TapStart can also send OSC-messages with the tempo/delay-value as argument 
> to any gives host and path.
> You can find more information on its page at 
> http://www.arnoldarts.de/drupal/?q=TapStart
> ofqf (http://www.arnoldarts.de/drupal/?q=node/573) is needed for the osc-part 
> and has to be installed beforehand.
> The direct-link to the source package is: 
> http://www.arnoldarts.de/drupal/files/downloads/tapstart/tapstart-0.1.tar.gz
> ofqf: http://www.arnoldarts.de/drupal/files/downloads/ofqf/ofqf-0.1.1.tar.bz2
> Have fun,
> Arnold
hi arnold,
i am having different problems installing tapstart.

well, installing 'ofqf' was almost trivial, i only had to change the 
QTDIR ntry in my .bash_profile to point to qt4 and to logout and login 
again, than it got builded.

but now, running scons on tapstart, i get following error:

scons: Reading SConscript files ...
Checking for pkg-config (at least version 0.0.0)... yes
Checking for QtCore...  yes
Checking for QtGui...   yes
Checking for ofqf (0.1.1 or higher)...  no

so what is the problem?

i already was runnung 'updatedb' as root and 'ldconfig' too, also i 
tried restarting the machine.
the fact is:


the pkg_config_path in my .bash_profile looks now like:


so, ofqf installed her .pc file in /usr/local/lib/pkg-config, and 
usually on my system the dir is called 'pkgconfig' and not 'pkg-config'.

but still i do not understand, i extended the PKG_CONFIG_PATH with 
/usr/local/lib/pkg-config and still it does not work.
i also tried to cp ofqf.pc into /usr/local/lib/pkgconfig, but this is 
not helping either.

arnold, i hope that you have some better idea than me?!


p.s. scons is v0.97-0d20070809-1 from debian-testing

More information about the Linux-audio-user mailing list