[LAU] Solved (I hope) Fedora Core 9, Planet CCRMA, and PulseAudio

The Other theother1510 at sbcglobal.net
Sun Dec 14 16:20:11 EST 2008

The Other wrote:
> Then I looked into the /etc/pulse/default.pa file, and went into the 
> ### Load Audio Drivers section and put in this:
> load-module module-alsa-sink
> load-module module-alsa-source device=hw:1,0
> and commented out everything in the ### Automatically Load Drivers 
> section so hal-detect wouldn't be used.
> That helped some.  But now I think I understand what is causing my 
> trouble.  The motherboard sound chip is getting recognized as hw:0 
> (default), and the Audigy2 ZS is getting recognized as hw:1.
> I think RealPlayer 11 is using hw:0 as the output, hence it's getting 
> kicked out on the motherboard speaker.  In prior versions of ALSA, I 
> remember a program called alsaconfig (or something close to that) that 
> let you specify the order of your sound chips/cards.  I would always 
> set the Audigy2 to become hw:0.
> I need something like this for PulseAudio.  Then some of these older 
> sound programs which always use hw:0 would be using the Audigy2 
> instead of the motherboard.

While trying to change the default sound card for hw:0, I looked at 
the end of the /etc/pulse/default.pa file.  There was a section 
labelled ### Make Some Devices Default.  This looked very promising.

Somewhere in the PulseAudio documentation I thought I saw something 
about being able to use the label for the hardware device.  So instead 
of saying hw:1,0, I tried using hw:[Audigy2] to specify the device.

In the ### Load Audio Drivers Statically section, I modified my lines to:

load-module module-alsa-sink device=hw:[Audigy2]
load-module module-alsa-source device=hw:[Audigy2]

Then in the ### Make Some Devices Default section, I added:

set-default-sink device=hw:[Audigy2]
set-default-source device=hw:[Audigy2]

Saved out and relogged in as a normal user.

Serendipity!  I had borked-up the PulseAudio Server so that it 
wouldn't connect/initialize/start-up/whatever it does.  I was no 
longer at the mercy of PulseAudio!

I then removed the alsa-plugins-pulseaudio RPM.  Now ALSA is in 
control of everything like it was before this upgrade to Fedora Core 
9.  The motherboard speaker is silent, as it always should be.

I can't run RealAudio 11 (I can configure it, but as soon as I tell it 
to play an internet radio stream RealAudio immediately closes itself 
and hides.)  But I can still use Firefox to play the internet radio 
stream, so I'm happy.

The moral of this story:  If PulseAudio is making your life miserable, 
give it some default sinks and sources that don't exist.  PulseAudio 
will go away and give you some peace.

Now, do I dare reboot this machine and find out that my method doesn't 
really work?    No way!

Thanks All,

More information about the Linux-audio-user mailing list