[LAU] options snd-hda-intel model=WHAT? for VIA VT1708

Roman Muñoz Roncal intxixu at gisa-elkartea.org
Wed Feb 13 05:44:36 EST 2008


You can get the information you need from here:


Note it is for kernel 2.6.24, but this document should be in your kernel 
sources, too. It will look very similar anyway

On this document, search for  "model-snd-hda-intel" (the biggest part, I 
think), then search for your codec, then search for your model 
description, then you know which one your model is.

If it does not appear, you are probably out of luck, but it could be 
that another model works. On an asus f3sv i tried model=lenovo and it 
worked, so search the Internet about your machine, card id, etc.

Final lines of text about module-snd-hda-intel will get you more 
information about at least two other issues thay may or not affect you, 
but it's worth reading

Anyway, you probably will get a working card, but it's very probably 
that you will get results not good enough to do serious audio work.

'2+ wrote:
> i bought an ARTiGO for my audio work
> this is a Pico-ITX machine which has VT1708 as its audio chip
> yes the trouble making HD-Audio type
> searching lots of sited talled me that i should find out the proper
> "options snd-hda-intel model=WHAT_I_WANT_TO_KNOW"
> in my /etc/modprobe.d/alsa-base
> some sites even tell me how to find out but that didn't work for this VT1708
> does somebody already have an answer?
> cat /proc/asound/card0/codec#* | grep Codec
> says:
> Codec: VIA VIA VT1708
> aplay -l
> says:
> **** List of PLAYBACK Hardware Devices ****
> card 0: VT82xx [HDA VIA VT82xx], device 0: VT1708 Analog [VT1708 Analog]
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
> card 0: VT82xx [HDA VIA VT82xx], device 1: VT1708 Digital [VT1708 Digital]
>   Subdevices: 1/1
>   Subdevice #0: subdevice #0
> i now have UbuntuHardyAlpha4 installed
> and ALSA works kind of beautiful
> but Jack doesn't make sound even though jackd and apps doesn't blame me anything
> alsamixer comes out in a kind of no PCM detedted(?) way
> the fader is there but there isn't 00 nor MM appearing under "PCM"
> tia

More information about the Linux-audio-user mailing list