[LAU] Mini-ATX synth is NOT going well

Ken Restivo ken at restivo.org
Sat Jun 21 15:50:01 EDT 2008

It booted within the first 20 minutes of owning it, weeks ago, so the hardware's fine.

Then I tried doing a 64studio install. It wouldn't boot off of the 64studio 2.0 CDROM ("unknown line in config file"). I figured out some goofy hack to force it to boot (I don't remember how exactly). Then, it complained about reading past the end of media on the CD-ROM... apparently the image didn't fit on my 800MB CDROMs using my particular burner. *sigh*

Fine, so I tried instead copying over my whole Debian Sid installation from my lappy to the 8GB USB key. Then installed Grub and did some reconfiguration. It booted! And it ran, even! Well, not really, every time it booted, fsck complained about unclean shutdowns ("unclean! unclean! banished!") and insisted on fscking. Every time it fscked, it created worse file system corruption, by completely botching inodes, wiping out directories ("You don't need this silly /usr/share/man/man1 do you? Fix<y>?".

Back to the drawing board. Wipe the USB key, mkfs it, and use debootstrap to install Etch. That worked fine. Then point to the 64studio repository, and run the 64studio-upgrade scripts. Works great, but takes 4 hours of downloading. Sheesh. Install Grub and do various configuration tasks (locales, fstab, kernel-img.conf, etc). Done. A fully-functional 64studio system! Then boot.... and the key's filesystem is again totally destroyed by fsck. Random inodes wiped out, directories and files in the wrong places. WTF??!?!!

For some reason, this particular PC (the micro-ATX with Celeron), insists on destroying the filesystem on my USB key. My laptop has no problem with it. It only appears to be mangled once the micro-ATX tries to boot off of it (or maybe installing grub is messing it up, that's possible too).

So right now I'm spending another 3 hours to download the 64studio 2.1 install disk. Instead of burning it, I'll just mount the image on my lappy and then do the debootstrap and 64studio-upgrade thing over and over again, to figure out where the problem is and the fail point is, without having to download the whole thing off the net every time.

At this point, my game plan is to install some kind of make-live (or whatever it is nowadays) tools, and try to make the USB key into a read-only, live setup. I don't want to use an actual live CD because I'm definitely going to need to update packages and add some stuff that's built from source. Also, there doesn't appear to be a live CD for 64studio 2.1 anyway.


More information about the Linux-audio-user mailing list