[LAU] M-Audio Transit on Fedora Core 8

Patrick Shirkey pshirkey at boosthardware.com
Mon Aug 31 19:55:20 EDT 2009

On 09/01/2009 09:37 AM, Louis Gorenfeld wrote:
> Hi,
>    I have a Fedora Core 8 machine that I am trying to get an M-Audio
> Transit to work on (USB audio device).  I am currently getting output
> via both aplay and jack (both with ardour and rosegarden), but haven't
> been able to get any input with arecord or these jack programs.  The
> input device opens fine, but I don't hear anything.  I have set the
> mic volume set to max using alsactl, and tried flipping a "mic
> capture" boolean also with alsactl.  I've also tried the latest
> vanilla kernel from kernel.org which comes with a later ALSA driver.
>    What is confusing is that this device works in Fedora Core 11, so
> I'm wondering what else could be different in FC11 that would cause
> this to work besides just a later ALSA driver set.  Updating to FC11
> is not an option at the moment.

I have an maudio quattro and the design is that output is little endian 
and input is big endian. Maybe that is affecting you too? There used to 
be a switch for this in jackd alsa flags. Seems to have disappeared now 

A way to test this is to record a short test with arecord and set the 
input to big endian.


Patrick Shirkey
Boost Hardware Ltd

More information about the Linux-audio-user mailing list