[LAU] Lash 0.6.0-rc2 compiling help

Joel Roth joelz at pobox.com
Mon Feb 2 18:45:18 EST 2009

Hi all,

I'd like to experiment with LASH, toward incorporating LASH
client functionality into Nama.

I could use a little help getting LASH to compile,
Lash-audio.org seems to be down. Perhaps someone here
knows what to do.

After some fiddling under my debian/sid distribution, I
start with configure thusly:

XML_LIBS=/usr/lib JACK_LIBS=/usr/lib READLINE_LIBS=/usr/lib/libreadline.so
JACK_CFLAGS=-I/usr/include ./configure

(Configure and its brethren seem to expect to find libs and 
includes under /usr/local.)

Right now the problem is in compiling simple_client.c:

gcc -DHAVE_CONFIG_H -I. -I../..  -I../..  /usr/include/ -I/usr/include/alsa   -g -O2 -MT lash_simple_client-simple_client.o -MD -MP -MF .deps/lash_simple_client-simple_client.Tpo -c -o lash_simple_client-simple_client.o `test -f 'simple_client.c' || echo './'`simple_client.c
simple_client.c: In function 'main':
simple_client.c:95: error: 'JackNullOption' undeclared (first use in this function)

I see JackNullOption is defined in /usr/include/jack/types.h,
so I tried adding this line to simple_client.c:

#include <jack/types.h>

and later

#include </usr/include/jack/types.h>

Still getting the same error.

Could there be a JACK version problem? LASH expects
jack_version > 0.99, but the latest JACK I have is 0.116.
I had just hacked that part:


Any suggestions or explanations by the C-savvy would be welcome.


Joel Roth

More information about the Linux-audio-user mailing list