[LAU] MusE problems (solved.. ish)

pete shorthose zenadsl6252 at zen.co.uk
Sun Feb 22 03:44:45 EST 2009

On Sat, 21 Feb 2009 10:38:03 +0100
Robert Jonsson <spamatica at gmail.com> wrote:

> Hi Pete,
> that does sound odd. I haven't tried regular 8.10 but the kubuntu 64-bit
> version builds muse 1.0rc1 here.
> There's no extra configuration you've done to qt? edited the configuration
> files or similar?
> I know it has happened to me a long time ago that qt had some ancient
> libraries added (probably by me) to .qt/qt_plugins that were not compatible
> and hence caused some of the build tools to crash instantly.
> Another thing to check is rights, are all files owned by you and writeable?
> But that is not very likely if you had the same problem with several
> tarballs.
> Does some other qt3 based package build?

Fmit also failed to build. I looked at the backtrace again and noticed that
uic was loading libQtCore from qt4 via dlopen just before the segfault.  !!!?

Having moved that out of /usr/lib I can now build qt3 applications. I'm reluctant to 
put it back in incase I return to find my laptop has turned into a Salvador Dali print.


More information about the Linux-audio-user mailing list