[LAU] jackd in realtime as user: a no-go in spite of modifying limits.conf

cal cal at graggrag.com
Sat Nov 21 03:25:22 EST 2009

Der Mickster wrote:
> Hey,
> Can't seem to start jackd in realtime as user on ubuntu studio. It
> does start as root, but that's hardly a consolation (unless I run all
> audio software as root, which would be kinda daft IMO)
> @audio - rtprio 99
> @audio - nice -10
> @audio - memlock unlimited
> have been added to /etc/security/limits.conf
> Nevertheless, starting it as user just doesn't seem to work, and I
> just can't figure out why. I've googled the issue, and everybody seems
> to agree that modifying limits.conf in the above manner should solve
> the problem - yet this is what I get:
> mick at kaizoku:~$ jackd -R -P89 -dalsa -dhw:0 -r48000 -p256 -n3 -S &
> [1] 3092
> mick at kaizoku:~$ no message buffer overruns
> jackd 0.116.1
> Copyright 2001-2005 Paul Davis and others.
> jackd comes with ABSOLUTELY NO WARRANTY
> This is free software, and you are welcome to redistribute it
> under certain conditions; see the file COPYING for details
> JACK compiled with System V SHM support.
> cannot use real-time scheduling (FIFO at priority 10) [for thread
> -1217255744, from thread -1217255744] (1: Operation not permitted)
> cannot create engine
> Any ideas?

Not sure if this is a possible answer to the question, or perhaps another
question altogether, but ... I've struggled with the same issue on a debian
system for some time, then discovered this in /etc/pam.d/su -

# Sets up user limits, please uncomment and read /etc/security/limits.conf
# to enable this functionality.
# (Replaces the use of /etc/limits in old login)
# session    required   pam_limits.so

So far, I'm still not sure if uncommenting the 'session required pam_limits.so'
line actually solves the problem, but I am curious.


(I dumbly sent this to just the op instead of 'reply all', so fwiw I'm repeating
it to the list)

More information about the Linux-audio-user mailing list