[LAU] Very frustrating problem with JACK and exporting through mixbus

Jason Jones poeticintensity at gmail.com
Sun Aug 19 03:54:25 UTC 2012

Just an update:  I built a completely new system last week.  The system I
was using before was an amd64 phenom2 6-core system with ATI graphics.  I
did a bit of research and found that generally, it seemed that Intel-based
systems out-performed AMD systems quite handily, so I decided to test it

My new system is an Intel Ivy-bridge i7 system with Intel 4500 integrated
graphics.  Everything in this box is new.  I'm using gentoo, and built the
kernel from scratch, so as to not have anything from the old system (along
with any potential mis-configurations causing problems) leak over to the
new system.

The first program I put on the system was ardour and mixbus.  I copied an
old session from the other box over, and loaded it up.

When I was finishing up this session originally, on the old computer, it
was pegging the DSP meter at 95%-100% consistently, causing me all sorts of

The same session loaded up on the Ivy-bridge system hit it no higher than
55%.  That made me smile.

Then I tried to export.  This is with Mixbus 2.1, by the way.  To my
surprise, it exported just fine.

I then tried to load and export another one, just to make sure it wasn't a
fluke.  Turns out, it was a fluke.  It didn't export, and exhibited the
exact same behavior as the old computer.  No exporting, the same error
messages, etc...  No big session was able to be exported since that first
one.  Made me want to say a few choice words.

Anyway...  That's the update.  I was hoping this problem was isolated to
some stupid configuration problem specific to my box, but it wasn't.

The good news is - the i7 processor seems to be doing *much* better than
the amd phenom2 was.  I'm excited to start recording with this new box!

I'll probably end up going back to JACK1 due to the exporting problem.
 Hopefully it doesn't have as many xruns with Intel as it did with AMD.


On Fri, May 18, 2012 at 6:22 AM, Harrison Mixbus <
mixbus at harrisonconsoles.com> wrote:

> Hi Jason,
> I've been keeping an eye on the list, hoping that one of the JACK devs
> would shed some light on this.
> We use Jack2 on OSX and Windows, and exporting seems to work fine there.
>  All of our Linux development and test systems use Jack(1).  I suppose we
> need to set up a linux test system with Jack2.
> I'll keep you updated.
> Best,
> Ben Loftis
> Harrison Consoles
>  Just an update on this...
>> I just created a full project with a combination of 39 tracks and busses
>> with A3, and with Jack2 everything exported just fine.  I haven't been able
>> to export anything but very small projects with mixbus and Jack2.  The
>> issue definitely seems to be related to mixbus, Jack2 and the size of the
>> project.
>> --Jason
>> On Sat, May 5, 2012 at 1:34 PM, Jason Jones <poeticintensity at gmail.com<mailto:
>> poeticintensity at gmail.**com <poeticintensity at gmail.com>>> wrote:
>>     I'm cross posting, including this to the JACK mailing list.
>>     On Sun, Feb 26, 2012 at 1:09 AM, Jason Jones
>>     <poeticintensity at gmail.com <mailto:poeticintensity at gmail.**com<poeticintensity at gmail.com>>>
>> wrote:
>>         Hey guys..  I recently acquired a RME Raydat interface (works
>>         like a *charm*, and I love it!), but ever since I installed
>>         it, I'm getting a random error when I try to export my tracks,
>>         and it's driving me bonkers.
>>         Previously to installing the Raydat card, I had used ardour
>>         for approximately 10 years, and have never experienced this
>>         problem.
>>         The problem is about 75% of the time, when exporting, the GUI
>>         will just sit there and do nothing, maintaining the "export"
>>         button depressed continually.   Within QJackctl's "message"
>>         window, I see the following error:
>>         JackEngine::XRun: client = ardour was not run: state = 2
>>         JackFreewheelDriver::Process: Process error
>>         00:31:20.920 XRUN callback (1).
>>         The remaining 25% of the time it exports just fine, without issue.
>>         Needless to say, this is extremely frustrating.  Googling the
>>         problem returns nothing but the snippet of code which contains
>>         the error message itself, which can be found at the link below:
>>         http://www.trac.jackaudio.org/**browser/jack2/branches/**
>> pipelining/common/**JackFreewheelDriver.cpp?rev=**4306<http://www.trac.jackaudio.org/browser/jack2/branches/pipelining/common/JackFreewheelDriver.cpp?rev=4306>
>>         Any help would be greatly appreciated.  If more info is
>>         needed, please let me know what I can get you.
>>         Also, thanks to everyone who assured me that the Raydat card
>>         works well under Linux.  It really does work like a charm.
>>         Regards,
>>         --Jason
>>         www.advancedbudgetstudios.com
>>         <http://www.**advancedbudgetstudios.com<http://www.advancedbudgetstudios.com>
>> >
>>     I've since found that this problem only occurs in Jack2.  Jack1
>>     exports 100% of the time just fine, but I've found that Jack2
>>     (aside from the export problem) works much better under high
>>     stress.  Most of my projects contain a high number of tracks /
>>     plugins / etc... Thus, high stress.  It'd be very nice to go back
>>     to Jack2, but not being able to export pretty much kills any
>>     usefulness from it.  Any ideas at all?
>>     Thanks in advance.
>>     --Jason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxaudio.org/pipermail/linux-audio-user/attachments/20120818/c536055f/attachment.html>

More information about the Linux-audio-user mailing list