[LAU] Jack chokes on merged device defined in .asoundrc

James Harkins jamshark70 at gmail.com
Tue Jun 19 01:39:35 UTC 2012

At Mon, 18 Jun 2012 18:02:44 +0200,
Pablo Fernandez wrote:
> I think this is related to the EHCI driver in your kernel version. Try
> with a more recent kernel, for example, the stock kernel in ubuntu
> 12.04. Read Clemens to understand the problem. Here:
> http://old.nabble.com/No-duplex-mode-with-the-EHCI-driver-and-USB-hub.-Is-the-problem-solved--td32799593.html

Looks promising. I've hesitated to upgrade to 12.04 because of some reports of USB audio devices not being recognized :-O

Probably what I should do is get another memory stick, put 12.04 "live" on it in and try out the device that way before committing to upgrade my main install.

Also (for the sake of paranoia or caution, if nothing else) -- I can't imagine why the low latency kernel for 12.04 would not have the patch, but stranger things have happened.

My situation seems to be a little different manifestation. I do get duplex operation with the m-audio -- 2-in + 2-out works fine in Jack. It's only when I try 2-in + 4-out that it dies. I tried this morning to test playback only:

/usr/bin/jackd -S -P60 -dalsa -r44100 -p1024 -n2 -Pft4 -s

... but no dice. ALSA says something about trying to acquire card Audio0 in addition to Audio1 (though there is no need to do so), and then I get a long string of "JackAudioDriver::ProcessSync: read error, skip cycle." This is the same error I got when I was trying the laptop's built-in hardware for capture and the four-channel device for playback. This puzzles me. I thought I was asking jack for playback only, but the behavior is the same as when I also requested capture from a different device. Maybe it's just that the merged device doesn't work at all with the kernel bug :)


PS Neither old.nabble.com nor mail-archive are inaccessible from mainland China, so it was a bit of an adventure trying to find those archived threads (including using Windows [ugh] and a free proxy service). Eventually got to:


James Harkins /// dewdrop world
jamshark70 at dewdrop-world.net

"Come said the Muse,
Sing me a song no poet has yet chanted,
Sing me the universal."  -- Whitman

blog: http://www.dewdrop-world.net/words
audio clips: http://www.dewdrop-world.net/audio
more audio: http://soundcloud.com/dewdrop_world/tracks

More information about the Linux-audio-user mailing list