[LAU] options for hard real time kernel for raring 13.04

Marco Donnarumma devel at thesaddj.com
Tue Sep 17 08:42:07 UTC 2013

update #2

@Jeremy, I found out my machine suffers of the same freezing windows bug as
yours when using the free driver. So I'm forced to get the nvidia driver
working properly. No luck with it yet.

@Jordan, thanks for your clarification. I had read your post [1] on the
nvidia forum before writing to this list. I've tried both methods for
Debian/Ubuntu that ulflj <https://devtalk.nvidia.com/member/1924456/> wrote
in that thread, but none worked out. I guess it's because I'm using an
older kernel 3.8 low latency and 3.2.6 rt.
[1] http://bit.ly/16aUlqD


after a wrong trial that left me only with tty, I went with:

\\\\\\ remove old nvidia stuff (it was corrupted in my case anyway)

dpkg --get-selections | grep nvidia
sudo apt-get purge {pkgs}

\\\\\\ get the installer and patch it with rt patch

boot in my low-latency 3.8 kernel tty level 3
downloaded the installer for 310.44 (the more recent driver that runs out
of the box with my low latency kernel)
./NVIDIA-Linux-x86-310.44 --extract-only
cd NVIDIA-Linux-x86-310.44/kernel/
patched it with Jeremy's patch: patch -Np1 -i nvidia-XXX-rt.patch
sudo nvidia-installer

This time apparently it worked for my low-latency kernel, but not for the
rt kernel (a 3.2.6 custom one I compiled). What's curious is that when
logging in the rt-kernel:

- cinnamon crashes and goes in fall back mode without a way of recovering it
- the nvidia module seems not to be loaded. I guess it's not because I
don't see the flash screen NVidia at booting
- so I launch the nvidia settings, and I'm welcomed with a message saying
I'm not using the driver
- so I launch the hardware driver utility, and I'm welcomed with another
message saying the driver is installed

What did I do wrong?
Shall I have run the installer when running the rt-kernel? and if so, why
is that, are modules kernel-dependent?

I'm just wildly guessing the rt-kernel fails in loading the module....

any hint, again, is much appreciated.

thank you!
best wishes,

Marco Donnarumma
New Media + Sonic Arts Practitioner, Performer, Teacher, Director.
Embodied Audio-Visual Interaction Research Team.
Department of Computing, Goldsmiths University of London
Portfolio: http://marcodonnarumma.com
Research: http://res.marcodonnarumma.com
Director: http://www.liveperformersmeeting.net

On Fri, Sep 13, 2013 at 7:55 PM, Nicola Di Marzo <
nicola.di.marzo at vodafone.it> wrote:

>  On 13/09/13 11:12, Marco Donnarumma wrote:
>   Hi Marco,
>> I recompiled a real time kernel for 13.04 following the system
>> configuration guide (in this case the italian translation that reports
>> "3.2.35-rt52").
>> http://linuxaudio.it/index.php/Configurazione_di_sistemi_audio_GNU/Linux#Compilare_il_tuo_real-time_kernel
>> I'm using an hp pavilion 6 laptop with the ua-25 ex soundcard and with
>> this particular real time Kernel everything works fine.
>> 1 xrun discovered at 5,8 ms latency in 3 hours session, recording and
>> mixing with Ardour.
>> Best regards
>> Nicola
>> >
>  Hi Nicola,
>  thanks for sharing your experience. The process in that tutorial is very
> similar to the one I followed from the other tutorial in English. It's good
> to know it works well, yet my problem is with the nvidia driver that needs
> to be patched for -rt as well.
>  thank you!
>  best,
>  M
> Hi Marco,
> Fortunately, i've never used proprietary drivers since i use Linux audio
> 'cause i always had intel video cards.
> Anyway, I'm interested in your issue and i will follow this thread, hope
> you will solve this soon!
> Regards
> Nicola
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxaudio.org/pipermail/linux-audio-user/attachments/20130917/81a44a81/attachment-0001.html>

More information about the Linux-audio-user mailing list