[LAU] no sound from zyn

Brian Sorahan brian at gospacecraft.com
Fri Oct 31 15:09:09 UTC 2014

Hi Jeremy,

On Fri, Oct 31, 2014 at 9:43 AM, Jeremy Jongepier <jeremy at autostatic.com>

> On 10/31/2014 03:33 PM, Brian Sorahan wrote:
> > Audio and MIDI are both set to JACK. Still no go.
> Hello Brian,
> Brace yourself, got a couple of questions ;)
> * Did you create the necessary connections?

Yes, I've connected zyn's output to JACK's system_playback ports.

> * Do other Jack-aware applications work?

Yes, did a test with supercollider.

> * Do the meters in ZynAddSubFX light up when you feed it MIDI?

Yes, my original email had details about getting MIDI to zyn. Even though I
have JACK MIDI selected under NIO settings in zyn, it only shows up under
the ALSA midi tab in qjackctl. I installed a2jmidid to get around this and
it seems to work fine. The meters light up, I've tweaked zyn's volume knobs
and according to the meters they are doing what they should be doing.

> * Did you try with the virtual keyboard of ZynAddSubFX?

Yes, no sound.

> * What if you use Zyn with ALSA MIDI and audio (zynaddsubfx -I alsa -O
> alsa)?

Haven't tried ALSA audio yet, but even if it worked I would still want to
get JACK audio working.

I've thought about trying yoshimi too, but feel like there is a high
probability I will have the same issue.

> Jeremy
> _______________________________________________
> Linux-audio-user mailing list
> Linux-audio-user at lists.linuxaudio.org
> http://lists.linuxaudio.org/listinfo/linux-audio-user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxaudio.org/pipermail/linux-audio-user/attachments/20141031/f5b04eee/attachment.html>

More information about the Linux-audio-user mailing list