[LAU] jackd core dumps in duplex mode

Gerhard Zintel gerhard.zintel at web.de
Mon Aug 3 17:03:32 UTC 2015

On Monday 03 August 2015, you wrote:
> On Sun, Aug 2, 2015 at 4:26 PM, Gerhard Zintel 
<gerhard.zintel at web.de> wrote:
> > jackd watchdog: timeout - killing jackd
> > Aborted (core dumped)
> You're device is likely configured incorrectly, so that JACK never
> actually gets woken up by the device, times out and deliberately
> kills itself.
> You need to use alsamixer or an equivalent to select the correct
> capture source on the device. This was a relatively common issue
> with Intel HDA chipsets a few years ago - I haven't been hearing
> about it as much recently.

Thanks a lot Paul for the pointer
Short story: jackd is running again in duplex mode. Case solved.

If no capture source is selected in alsamixer, why does capture only 
mode work in jackd without problems and times out as soon as duplex 
mode is selected? Strange.

I tried to tune the settings in alsamixer before bothering the list. 
For weeks I tried all permutations in alsamixer and qjackctl without 
success. Today, after your response, I opened alsamixer again, two 
devices (Capture and Capture1) have been in Capture mode. I switched 
off both, switched only Capture into capture mode and jackd started 
in duplexmode without problems. Out of curiosity I tried to recreate 
the old behavior - no chance, it's not longer possible. Even if I 
switch on / off capture mode for both Capture devices and chose 
different hardware interfaces in qjackctl (hw:0 = HDA Intel PCA, 
hw:0.0 = VT2020 analog) jackd starts trouble-free for all 
combinations. I do not really know the culprit. Alsa and jackd are 
still black boxes to me.

Again, thanks a lot

More information about the Linux-audio-user mailing list