[LAU] jackd core dumps in duplex mode

Paul Davis paul at linuxaudiosystems.com
Tue Aug 4 02:47:28 UTC 2015

On Mon, Aug 3, 2015 at 1:03 PM, Gerhard Zintel <gerhard.zintel at web.de> wrote:

> Nonetheless:
> If no capture source is selected in alsamixer, why does capture only
> mode work in jackd without problems and times out as soon as duplex
> mode is selected? Strange.
> Furthermore:
> I tried to tune the settings in alsamixer before bothering the list.
> For weeks I tried all permutations in alsamixer and qjackctl without
> success. Today, after your response, I opened alsamixer again, two
> devices (Capture and Capture1) have been in Capture mode. I switched
> off both, switched only Capture into capture mode and jackd started
> in duplexmode without problems. Out of curiosity I tried to recreate
> the old behavior - no chance, it's not longer possible. Even if I
> switch on / off capture mode for both Capture devices and chose
> different hardware interfaces in qjackctl (hw:0 = HDA Intel PCA,
> hw:0.0 = VT2020 analog) jackd starts trouble-free for all
> combinations. I do not really know the culprit.

This is device specific behaviour and there is no generic explanation.

> Alsa and jackd are
> still black boxes to me.

neither ALSA nor jackd are really to blame for the situation. it is
caused by the pinouts/configuration of an Intel HDA chipset by the

More information about the Linux-audio-user mailing list