[LAU] "Cannot open lsp client" ??

david gnome at hawaii.rr.com
Thu Nov 19 09:18:58 UTC 2015

On 11/18/2015 04:37 PM, James Harkins wrote:
> Can anyone provide some insight into the following JACK error?
> Cannot open lsp client jack_client_open() failed, status = 0x21
> Background: SuperCollider has an extension class, SCJConnection[1],
> that uses jack_lsp to query a running jack server for ports,
> properties and connections. This has never failed for me. In fact, at
> 8 AM today, it was fine. Then I needed to step away, so I closed
> audio apps, stopped the Jack server (using qjackctl) and suspended my
> Ubuntu session. A bit later, I resumed the session, restarted the
> Jack server, launched SC, and it spit out "Cannot open lsp client"
> for the same action that had worked perfectly two hours before.
> Quitting and restarting the Jack server did not resolve the problem.
> Rebooting the computer resolved the problem.
> If it's impossible to determine the cause at this point, that's fine
> -- I've seen stranger things from computers. But it's troubling that
> something that has worked literally thousands of times would
> suddenly, today, fail for no apparent reason. So I'm hoping maybe
> somebody might have a guess what would cause lsp to break (and I can
> keep that in mind if it happens again).
> hjh
> [1]
> https://github.com/supercollider-quarks/LinuxExternal/blob/master/JACK/SCJConnection.sc

My general experience has been that very little audio hardware handles 
suspension. My USB soundcard, for example, does not. But you said lsp 
was working before you suspended, so I have no idea beyond Ubuntu 
sneaking in an update????

David W. Jones
gnome at hawaii.rr.com
authenticity, honesty, community

More information about the Linux-audio-user mailing list