[LAU] Laptop sound problems

Bill Purvis bill at billp.org
Wed Sep 28 09:28:04 UTC 2016

On 27/09/16 14:51, Len Ovens wrote:
> On Tue, 27 Sep 2016, Bill Purvis wrote:
>> I use my laptop for all sorts of things - browsing, editing 
>> development and
>> make use of various programs (I hate the word apps) that produce 
>> audio: totem,
>> firefox (YouTube etc.) and I don't see any easy way to avoid 
>> pulseaudio. I understood
>> that the versions of pulseaudio from the LAU distribution were fully 
>> aware of Jack, and they
>> have proved to work in most cases.
>> For the record, the versions of pulseaudio modules installed are:
> you need module-jackdbus-detect. the package is pulseaudio-module-jack 
> in debian/ubuntu. You also need to use jackd2 rather than jackd1.
> -- 
> Len Ovens
> www.ovenwerks.net
Installed that, but still no sound. Shut down Jackd and it bursts into 
Tried to restart Jack but it fails:

10:01:19.105 D-BUS: JACK server could not be started. Sorry
Wed Sep 28 10:01:18 2016: Starting jack server...
Wed Sep 28 10:01:18 2016: JACK server starting in realtime mode with 
priority 10
Wed Sep 28 10:01:18 2016: self-connect-mode is "Don't restrict self 
connect requests"
Wed Sep 28 10:01:19 2016: Acquired audio card Audio0
Wed Sep 28 10:01:19 2016: creating alsa driver ... 
Wed Sep 28 10:01:19 2016: Using ALSA driver HDA-Intel running on card 0 
- HDA Intel PCH at 0xc2510000 irq 45
Wed Sep 28 10:01:19 2016: ERROR:
ATTENTION: The playback device "hw:0" is already in use. The following 
applications  are using your soundcard(s) so you should check them and 
stop them as necessary before  trying to start JACK again:
pulseaudio (process ID 2296)
Wed Sep 28 10:01:19 2016: Released audio card Audio0
Wed Sep 28 10:01:19 2016: ERROR: Cannot initialize driver
Wed Sep 28 10:01:19 2016: ERROR: JackServer::Open failed with -1
Wed Sep 28 10:01:19 2016: ERROR: Failed to open server
Wed Sep 28 10:01:20 2016: Saving settings to 
"/home/bill/.config/jack/conf.xml" ...
10:01:25.792 Could not connect to JACK server as client. - Overall 
operation failed. - Unable to connect to server. Please check the 
messages window for more info.
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started

(above taken from Qjackctl Messages window)
process 2296 is, of course pulseaudio:

     bill      2296  1.1  0.0 861316  8004 ?        S<l  Sep27 12:34 
/usr/bin/pulseaudio --start --log-target=syslog

This was after a reboot of system.
Ran pacmd list-modules which showed module-jackdbus-detect presnt but 
not module-jack-sink or module-jack-source.
confirmed that I'm running jackd2 not jackd1:

     $ dpkg -S /usr/bin/jackdbus
     jackd2: /usr/bin/jackdbus

When does pulseaudio use module-jackbus-detect to check if jack is 
running? Do I need to start jack
before pulseaudio?

Tried pacmd load-module module-jack-source and module-jack-sink. They 
them show up in pacmd list-modules
but still totem hangs when started.


| Bill Purvis                            |
| email: bill at billp.org                  |

More information about the Linux-audio-user mailing list