[LAU] Mtrack-8 oddity

David W. Jones gnome at hawaii.rr.com
Fri Aug 23 00:55:27 CEST 2019

On August 22, 2019 8:04:34 AM HST, Will Godfrey <willgodfrey at musically.me.uk> wrote:
>I've had one of these running perfectly for near 2 years now and have
>run it with a buffer size of 64 frames/48kHz. This last week I've been
>too busy
>with 'other things' to do any composition. However, yesterday when I
>tried to
>run it. Jack immediately went into a cascade of Xruns with a most
>error report, suggestion it couldn't find the unit.
>Running Yoshimi by itself under Alsa worked fine, so I was now totally
>perplexed. Eventually I noticed that Yoshimi was set to 128 frames.
>When I set
>it to 64, it was even stranger. It ran, but on attempting to play
>anything it
>just made a horrible noise. Further tests revealed that jack also ran
>with 128 frames or more.
>For a while I couldn't think of anything that had changed during that
>week - no
>upgrades or installs. Then I remembered I'd had to repair a bad solder
>joint in
>the amplifier, and as everything is mounted in a rack, had to pull
>quite a bit
>of stuff apart to get to it. I was quite sure I'd checked everything
>re-assembling it, but just to be sure did a quick 'lsusb' in a terminal
>and as I thought, audio, midi, and mouse/keyboard were all on a
>internal bus, and no bus had anything else on it.
>Today, while playing a CD on my 'office' machine I remembered I used to
>have a
>USB CD player that wouldn't work when plugged into the front USB3
>sockets, even
>though it was identified on an internal USB2 bus, so checking the music
>I had indeed plugged it onto one of these on the back of that machine.
>swapped into a (black) USB2 socket it once again worked fine.
>I've no idea why it had given the symptoms it did though!

USB ports and "standards" can be weird. I had a cheap but excellent Canon scanner that used USB2. It worked beautifully when connected to an USB2 port controlled by an actual USB2 controller. Connect to a USB2 port controlled by a USB3 controller? Nope, no go, nothing, regardless of OS.

Glad the problem got sorted out. You may now return to composition, your audience here eagerly awaits your music!

David W. Jones
gnome at hawaii.rr.com
authenticity, honesty, community

Sent from my Android device with F/LOSS K-9 Mail.

More information about the Linux-audio-user mailing list