[LAU] problem with zita-bridge to use two recording interfaces -- some extra info

soffioalcuore at posteo.net soffioalcuore at posteo.net
Sat Dec 21 11:40:20 CET 2019

Hi Fons,

thanky you very much for your help!
now it works.

I was already in the realtime and also in the audio group, in fact, I
had modified limits.conf manually when setting up the system, and
later, I guess, had also installed the realtime-privileges package. 

also I checked the priority settings of the jack daemon. Somewhere I
read  priority should be between 50 and 70 or so. so I had this set
already, too; maybe not for every soundcard, though.
but, what also seems to be important - quite logically, if I read your
recent hints on the realtime-settings - is to tell the jack daemon to
run in realtime mode. Here, in qjackctl the related checkbox was
unchecked; I did that because I recently tried to start linux with the
arch stock kernel instead of the realtime kernel, just to see how this
works with my audio usage. And I thought if I don’t run the rt-kernel,
I have to uncheck the realtime-setting in qjackctl, which may be a
misconception (?).
now, with it enabled, zita-ajbridge works very well.

again, thank you very much!

Am Freitag, den 20.12.2019, 21:49 +0100 schrieb Fons Adriaensen:
> Hi Christoph, 
> Some extra info:
> In case your system does allow real-time, it could be
> that the maximum priority is set too low.
> Zita-ajbridge will run the thread talking to the ALSA
> device with a priority that is 10 higher than Jack's
> callback threads. So if your jack is configured for
> e.g. 80, and the system limit is 85, zita-ajbridge
> will fail.
> Ciao,

More information about the Linux-audio-user mailing list