[LAU] threadirqs suspected to cause xruns

Moshe Werner moshwe at gmail.com
Fri Aug 28 15:02:28 CEST 2020

Hello everyone,

so I ran into trouble with a new machine I built recently.
It appears to be that when I enable threadirqs or use an rt-Kernel, I am
getting an xrun inferno.
At first everything is fine but after a few seconds/minutes of playback I
get thousands of xruns.

I am on Manjaro (KDE),  the kernels I tried so far are
5.8.3-2 - working ok'ish without threadirqs enabled
5.6.19_rt12-3 - bad
5.4.59_rt36-1 - bad

The funny thing is that I had a nice running system at first (around two
months ago) on the same machine, the xruns started suddenly out of the
blue. (Kernel update?)

Configuration is
Ryzen 5 3600
B450 Aorus pro
Motu 1248
Manjaro KDE

I tried to higher the buffers to 2048, didn't help.
I installed an USB2 PCIe card so that I could separate the usb audio
interface from other stuff and prefer its IRQ with rtirq.
Nothing helped.

What could be wrong?

I would love to hear your opinions

Best regards
Moshe Werner
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.linuxaudio.org/archives/linux-audio-user/attachments/20200828/899dc530/attachment.html>

More information about the Linux-audio-user mailing list