[LAU] sound with Scarlett 3rd Gen device?

Iain Mott mott at escuta.org
Fri Jan 31 11:05:59 CET 2020

Hi Christoph and list, reporting back: It seems the problems, 
particularly on the laptop, are related to Ubuntu. Last night I made a 
live USB stick of AV Linux. Booting from this both solves the problem of 
the USB ports and produces glitch free audio (thus far). I got ins and 
outs working with Pd + jack with frames/period set to 64, sample rate 
48hHz, and periods/buffer 3. Latency of 4msec, so I'm happy with that 
(Pd gave segmentation faults on startup at lower frame rates). The Pd 
test (playing a tone and monitoring mic input) did much better than it 
did on Windows (portaudio/asio) where I still heard occasional glitches 
(don't remember the latency value).

Christoph and others using the Scarlett, what Linux distributions are 
you using?

 >Is is USB Class compliant or does it come with specific hardware features?
 >If it does, maybe you can switch from "special" to "compliant" mode?

I believe it is class compliant except for configuration process.  How 
would one "switch from special to compliant"?

I've heard of people having success using Wine to run Focusrite Control, 
so I'll try this too.

All the best,


Em 31/01/2020 04:10, Christoph Kuhr escreveu:
> Hi Iain,
> no, I don't have a gen3.
> Is is USB Class compliant or does it come with specific hardware features?
> This worked for my RME babyface pro though.
> Hope this helps...
> Best
> Ck
> -- 
> Diese Nachricht wurde von meinem Android Mobiltelefon mit WEB.DE 
> <http://WEB.DE> Mail gesendet.
> Am 30.01.20, 11:47 schrieb Iain Mott <mott at escuta.org>:
>     Hi Christoph, I don't doubt for a minute that I'm doing something
>     silly, but do you mean the monitor and headphone gain knobs on the
>     front? Yes, they're both up. When I switch directly to windows,
>     everything is working: pd (ASIO driver "via portaudio"),
>     SuperCollider, Ardour, etc., but in Linux, silence....
>     You have a 3rd gen interface?
>     Cheers,
>     Iain
>     Em 30/01/2020 07:26, Christoph Kuhr escreveu:
>         Hi Iain,
>         did you turn up the hardware volume?
>         I had this problem. Someone truly evil turned it down, while I
>         wasn't watching... ;-)
>         BR,
>         Ck
>         -- 
>         Diese Nachricht wurde von meinem Android Mobiltelefon mit
>         WEB.DE <http://WEB.DE> Mail gesendet.
>         Am 30.01.20, 10:24 schrieb Iain Mott <mott at escuta.org>:
>             Dear Linux audio people,
>             I have a Scarlett 18i20 3rd Gen interface which I'm trying
>             to use on a
>             recent Samsung laptop with Ubuntu 19.04.
>             The 3rd gen devices are apparently shipped in
>             non-functional "MSD" mode,
>             so I registered and activated the device using Windows 10
>             following the
>             instructions on the Focusrite website. Tested it there
>             with Ableton Live
>             Lite (provided via registration of the device) and also
>             Ardour. It works
>             fine. To get it to work on Ardour it was necessary to use
>             the ASIO
>             driver in the Ardour audio configuration. I had removed
>             ASIO4ALL before
>             installing the Focusrite/Scarlett software as suggested,
>             so perhaps this
>             driver came with Focusrite install.
>             Now with the device apparently configured and the routing
>             done in
>             Windows using the Focusrite Control software (i thinks
>             that's the name,
>             I had selected output channels 1 and 2 to connect with the
>             monitors/headphone jack), I returned to Linux. The
>             Scarlett device is
>             detected by lsusb, qjackctl and pavucontrol. Jack runs
>             with no errors
>             when the Scarlett is selected as the i/o device and all
>             the correct
>             channels appear in the Connect window. No sound however is
>             heard through
>             the phone jack, nor if i plug the phones directly in to
>             the output jacks
>             at the back. I tested using VLC configured for Jack output
>             and also with
>             pd -jack.
>             With jack turned off and with VLC audio out set to
>             pulsaudio, I set the
>             Scarlett 18i20 as the preferred device in pavucontrol.
>             With VLC playing
>             the output VU meter for the Scarlett is active in
>             pavucontrol but there
>             is still no sound coming out of the device itself.
>             Has anyone managed to get a 3rd generation Scarlett to
>             work on Linux?
>             Can anyone suggest please what I can do?
>             Thanks!
>             Iain
>             PS. i did see an unresolved thread on this list last year
>             about a 3rd
>             gen Scarlett. I'll send a message to the author to see if
>             the problem
>             was fixed.
>             _______________________________________________
>             Linux-audio-user mailing list
>             Linux-audio-user at lists.linuxaudio.org
>             https://lists.linuxaudio.org/listinfo/linux-audio-user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.linuxaudio.org/archives/linux-audio-user/attachments/20200131/bd3e2424/attachment.html>

More information about the Linux-audio-user mailing list