[LAU] zita-jacktools help needed

vince azvinz at yahoo.de
Sat Jun 13 23:00:34 CEST 2020

Hello everyone,

I'm trying to install and use zita-jacktools, but unfortunately I don't 
get it to work.

I managed to compile it and install it.
According to 
I needed also to compile zita-convolver 4.0.0 first, which I did, and 
which also went well.

I've done the following:

1. download and unpack:
- zita-audiotools
- zita-jacktools
- zita-jclient
- zita-convolver 4.0

2. make and install zita-jclient and zita-convolver:
- go to source, them make, then sudo make install

3. install zita-audiotools and zita-jacktools:
- go to folder, then python3 setup.py build
- then install with sudo python3 setup.py install

Now I can import jacktools in Python without errors. But if I try to use 
it OR to run an example file (e.g. tobspect.py like in the ccc video), I 
get the following error:

ImportError: libzita-jclient.so.0: cannot open shared object file: No 
such file or directory

In the nabble thread, a user said that zita-jclient is installed to
/usr/local/lib64, but zita-jacktools only included /usr/lib as the 
library path.

So I copied libzita-convolver and libzita-jclient from /usr/local/lib64 
to /usr/lib, but I still get the same error message.

Does someone have any hint? I'm developing a open source Python 
application, where I really need fast and rock solid interpolation for 
the mixer faders, so I'd really love to use JackGainctl for this....

Here the full error message:
File "/media/sda7/Programming/Python/jacktooltest/main.py", line 3, in 
     from jacktools import jackkmeter
"/usr/local/lib/python3.6/dist-packages/jacktools/jackkmeter.py", line 
22, in <module>
     from jacktools.jackclient import JackClient
"/usr/local/lib/python3.6/dist-packages/jacktools/jackclient.py", line 
21, in <module>
     from jacktools import jackclient_ext
ImportError: libzita-jclient.so.0: cannot open shared object file: No 
such file or directory

Thank you for any help!

All the best,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.linuxaudio.org/archives/linux-audio-user/attachments/20200613/92891b25/attachment.html>

More information about the Linux-audio-user mailing list