[LAU] HSP/HFP profiles not working on most recent Linux audio / bluetooth stack?

S. sb56637 at gmail.com
Tue Jun 23 16:25:53 CEST 2020

Hi there, I run openSUSE Tumbleweed and Leap 15.2 (beta) on different machines. I just did a fresh install of both on two different laptops, with the Mate environment. On the Leap system with slightly older package versions I can use Pavucontrol to switch between HSP/HFP and A2DP profiles on both of my bluetooth headsets, and they work on HSP/HFP for both input and output. However, on the newer Tumbleweed system I can switch the profile to HSP/HFP in Pavucontrol but it doesn't work, Audacity just freezes and VLC/Firefox playback freezes until I switch it back to A2DP. Which is obviously preferable for listening, but the problem is I need to record some low quality audio via HSP/HFP.

So I'm wondering which package version is making the difference. The two systems are configured almost identically. I tried the Leap kernel (5.3.18) on the Tumbleweed system, but it made no difference. Here are a few key package differences, please let me know if you think of anything else:

     bluez 5.54
     kernel-firmware-bluetooth 20200519
     libbluetooth3 5.54
     libgnome-bluetooth13 3.34.1
     pulseaudio 13.0
     alsa 1.2.3
     alsa-firmware 1.2.1

Leap 15.2:
     bluez 5.48
     kernel-firmware-bluetooth (package doesn't exist)
     libbluetooth3 5.48
     libgnome-bluetooth13 3.34.0
     pulseaudio 13.0
     alsa 1.1.5
     alsa-firmware 1.0.29

I also tested Ubuntu 20.04, but it was the total opposite. Both of my bluetooth devices only connected via HSP/HFP, and the only way I could switch to A2DP was manually via `bluetoothctl`. I believe Ubuntu 20.04 has kernel 5.4, not sure about the rest of the stack.

More information about the Linux-audio-user mailing list