[LAU] aconnect oddities

Jeanette C. julien at mail.upb.de
Tue Mar 17 15:38:38 CET 2020

Mar 17 2020, Max has written:
> It gets weirder. Trying different escaping
> $ aconnect tickle:0 'Pure Data':1
That quotation might not work at all, because you quote only part of the
port name anyway.
Still, have you checked that the ports aren't connected already? That
might be a reason.
I usually use quoting with double quotes, but have also tried single
quotes, as you did, and escaping a space character with a backslash,
which also worked.

Also you say that "Pure Data:1" is an input port. Just, because there
can be confusion with input and output, especially when hardware ports
are involved: will PureData read MIDI from that port into the program?
Normally aconnect complains if you don't sort portnames correctly on the
commandline. First the port that produces MIDI and then the port that
consumes/reads MIDI.

Alternatively: if it is possible for you to use a graphic desktop
environment in this situation, you can find very handy patch bays, which
will take care of all these oddities.

Best wishes,


  * Website: http://juliencoder.de - for summer is a state of sound
  * Youtube: https://www.youtube.com/channel/UCMS4rfGrTwz8W7jhC1Jnv7g
  * SoundCloud: https://soundcloud.com/jeanette_c
  * Twitter: https://twitter.com/jeanette_c_s
  * Audiobombs: https://www.audiobombs.com/users/jeanette_c
  * GitHub: https://github.com/jeanette-c

Just call out my name, and I will be there... <3
(Britney Spears)

More information about the Linux-audio-user mailing list