[LAU] Trouble using BinauralDecoder from iempluginsuite

Iain Mott mott at escuta.org
Sat Dec 24 07:34:34 CET 2022


I've been trying to improve the ambisonic decoding for a project in 
SuperCollider on Arch Linux. Typically I use newCIPIC decoder kernel 
from the ATK. As an alternative, I first tried the ambix VST plugin in 
Ardour. When I could get it to work I got excellent results, however it 
crashed Ardour constantly and the standalone version was equally 
unstable. The ambix project seems to have stopped development more than 
2 years ago.

I then tried the VST version BinauralDecoder from iempluginsuite. This 
works well in Ardour testing with a 2nd order N3D signal. The standalone 
version however fails to produceĀ  an output and seems to be caught in a 
constant internal feedback loop, ie. it shows "INPUT MUTED" when the 
audio settings have "Feedback loop: mute audio input" selected and also 
produces feedback when set to ALSA (rather than Jack) and the "test" 
button selected. This feedback occurs with no input connections in Pipewire.

In SuperCollider (from which would be the ideal platform for me to use 
the BinauralDecoder), I again attempted to use the VST version using 
VSTPlugin and its associated classes. When however I scan for plugins 
with VSTPlugin.search, it prints:

'/usr/lib/vst3/BinauralDecoder.vst3' is black-listed.

I've not been able to find where that blacklist is located. The same 
plugin continues to work correctly in Ardour. The version installed of 
the iempluginsuite is the latest: 1.13.0-1.

Does anyone have any suggestions?

Merry Christmas,

More information about the Linux-audio-user mailing list