[LAU] Alsa not finding soundcard

Bengt Gördén bengan at bag.org
Wed Oct 5 16:51:11 CEST 2022

On 2022-10-05 10:32, Fons Adriaensen wrote:
> Hello all,
> A friend of mine, who is mainly a Windows user and has limited knowledge of
> Linux, has two HP laptops running Archlinux.
> One of them works perfectly with an RME Octamic-XTC. The other doesn't
> seem to detect it as a sound card (it doesn't show up in aplay -l).
> On both the RME is recognised as an USB device (by lsusb).
> I'm trying to help him fix this (remotely). We compared kernel and alsa
> versions, they are the same. In fact the two Linux installations should
> be identical, both had a full update before I shipped to two laptops
> to him.
> What could be the problem on the second PC ?

I have an HP Z2 Tower G4 Workstation for my music and a Soundcraft Signature 12 
MTK as my main interface. Oddly enough, I had almost the same problem when I 
switched workstation from Dell to HP in early 2020. The first time I installed 
my distro (ubuntustudio), MTK was not recognized. I tested with lsusb and there 
was the interface but not in alsa -l. I stumbled on the thread below and tried 
with qjackctl and then it worked. No idea why that happened. After a power 
outage a few months ago, the same thing happened. I did the same thing and ran 
qjackctl and then it works again, both restarting and pulling out and in the 
interface. Inexplicable but maybe a workaround.



More information about the Linux-audio-user mailing list