[Jack-Devel] Recorded from OSS /dev/dsp sound is too high pitched on FreeBSD

Dan MacDonald allcoms at gmail.com
Mon Jan 9 17:26:07 CET 2017

I'm very interested in Yuri's results as I'd like to use JACK under
FreeBSD. Supposedly (theoretically) both Ardour 5 and MusE 3 git should be
able to run under FreeBSD these days.

Anyone using JACK under BSD is dependent upon JACK's OSS driver but last
time I tried JACK under a FBSD 11 pre-release it failed to start at all. I
haven't tried it since 11-RELEASE.

On Mon, Jan 9, 2017 at 4:16 PM, Chris Caudle <chris at chriscaudle.org> wrote:

> On Mon, January 9, 2017 12:06 am, Yuri wrote:
> > My OSS device with the mike doesn't accept 48000. During
> > sysctl(SNDCTL_DSP_SPEED) it always falls back to 32000. Jack fails to
> > process this properly and records the signal with the wrong pitch.
> I looked back at your first email and you never showed the entire output
> from jackd as it starts.  The console messages printed should display the
> determined paramaters.  On ALSA systems there is a message showing what
> sample rate is used if it is not the same as the sample rate requested.
> Maybe OSS does not return that information.  That would be a limitation of
> OSS or maybe an error in the jackd OSS driver, not a generic jackd
> problem.  I have never heard of anyone using the OSS driver, how many
> users of that are there?
> --
> Chris Caudle
> _______________________________________________
> Jack-Devel mailing list
> Jack-Devel at lists.jackaudio.org
> http://lists.jackaudio.org/listinfo.cgi/jack-devel-jackaudio.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.linuxaudio.org/archives/jackaudio/attachments/20170109/6d1fb0c1/attachment.html>

More information about the Jackaudio mailing list