[linux-audio-user] m-audio quattro and alsa mixer

Patrick Shirkey pshirkey at boosthardware.com
Thu Oct 17 12:11:00 EDT 2002

m wrote:
> hi,
> i've just got a m-audio quattro (very nice :) and have alsa running
> happily... but i'm having trouble starting the alsamixer. 
> i've copied in Patrick Shirkey's scripts for .asoundrc and qinit, but
> when i run qinit it segfaults :(... alsamixer says 'no mixer elems
> found' and when i run gnome-alsamixer i just get a blank screen with
> 'USB Audio Quattro' at the top. i'm getting sound fine out of
> applications such as xmms though... although SpiralLoops crashes and/or
> produces digital glitch noise when i import a sound.... 
> any ideas?

Are you using cvs or 0.9rc3? Can you send the output of qinit? BTW I 
didn't write it. Takashi whipped it up for me while we were testing and 
it has become part of my startup scripts so I thought it would be useful 
for other users too.

Apart from that the quattro has no mixer elems. The only way you can 
adjust the volume is using the output level buttons on the box or using 
software mixing like in ardour, alsaplayer, xmms (equilisation). You 
should be using an analog mixer with it if you want to record at 
sufficient volumes.

Patrick Shirkey - Boost Hardware Ltd.
For the discerning hardware connoisseur
Http://www.djcj.org - The Linux Audio Users guide

"Um...symbol_get and symbol_put... They're
kindof like does anyone remember like get_symbol
and put_symbol I think we used to have..."
- Rusty Russell in his talk on the module subsystem

More information about the Linux-audio-user mailing list