[linux-audio-user] PlanetCCRMA - RealPlayer -artsd problems

Dave Phillips dlphilp at bright.net
Mon Mar 31 16:03:00 EST 2003

Hi Fernando:

  Yes, it was running, but he (my client) told me that it was broken
when he tried running RP without artsd too. He also informed me that he
had not rebooted the machine for a couple of days, and I'm wondering if
our MusE adventures knocked out an audio device. Is that possible ?

== dp

Fernando Pablo Lopez-Lezcano wrote:
> >   I installed RealPlayer on a machine running RH 8.0 and PlanetCCRMA. At
> > first it worked fine, but now it gets the following error on startup
> > under KDE :
> >
> >       SNDCTL_DSP_SETFMT failed
> >       Cannot allocate memory
> >
> >   Anyone know how to resolve the problem ? Is artsd the culprit here ?
> Hmmm, why artsd? Do you have it running?
> >   RealPlayer also complains that another application has the sound
> > device. Weird: this machine has a SBLive installed with the PlanetC ALSA
> > drivers, I don't understand why RealPlayer complains about not being
> > able to access the device. So, how do I check to see who's hogging the
> > resources ?
> I think you can use "fuser", so for example do:
>   fuser /dev/dsp
> and it should tell you which processes if any are using the resource...
> I think realplayer uses the oss api.
> -- Fernando

More information about the Linux-audio-user mailing list