[linux-audio-user] alsa rtc patch in 2.4.23?

James Stone stone1 at btinternet.com
Fri Jan 9 04:52:51 EST 2004

On Thu, Jan 08, 2004 at 12:38:51PM -0600, Jack O'Quin wrote:
> James Stone <stone1 at btinternet.com> writes:
> > I still had a problem when I tried to enable capabilities with the
> > patch for jack. When I ran jack with startjack as a normal user, it ran
> > for a short while then stopped (can't remember the error message now.. I
> > changed back to the unpatched kernel and now start jack as root). Any
> > hints on how to get this working would be appreciated.
> The messages would be helpful.  You did this by applying the normal
> capabilities patch[1] by hand?  I haven't tried that yet, because I've
> been experimenting with Linux Security Modules.  

Yep thats right.. Don't know what went wrong as it seemed to work when
I tried it the second time. I think I had set RTC as a module in kernel
and not sure if it was loading properly.. Also I had not set my MB
chipset in the kernel so everything was slow, so that could have been
adding latency problems.. anyway, it is working now. I can't get as good
latencies as you but then I am using a SBLive! Seems relatively stable
in full duplex at 2 / 512.

> If you like to live dangerously, here's[2] a preliminary realtime LSM
> for 2.6 you can try.  It works with an unpatched kernel, but you need
> kernel sources to build it and install it.
>   [1] http://jackit.sourceforge.net/docs/faq.php#a5
>   [2] http://www.joq.us/realtime

The module looks interesting. I think I will wait til it gets into the
kernel to try it though. (knowing me this will mean I will probably try
it out in the next few days!! ;) )


More information about the Linux-audio-user mailing list