[linux-audio-user] linux and alsaplayer

Mark Knecht mknecht at controlnet.com
Fri Jan 23 16:06:38 EST 2004

> I'm running gentoo kernel 2.20-gentoo-r8.
> I start jack (0.91.1) with  jackd -vR -d alsa  ,as root.
> muse is working (if started as root)
> so is ardour
> But when I try Alsaplayer -o jack somefile.someformat,
> it says "Failed to load output plugin "jack". Trying defaults."
> When I shut down jack alsaplayer starts playing perfectly
> Does it have something to do with the asoundrc-science?
> I tried copiing the jack-plugin text for .asoundrc somewhere
> from the alsa-site, the same result
> I thought it should work without the .asoundrc,but maybe I'm wrong.
> Anyone knows what I'm missing?

emerge -vp jack-audio-connection-kit.

I think you will not see jack as a flag. I had the same problem this morning
for some reason. Check to make sure you have the jack flag in make.conf and
make sure you are using the ~x86 version. For some reason it looked like the
current stable version doesn't use jack, so I went to ~x86 and everything
was fine.

- Mark

More information about the Linux-audio-user mailing list