[linux-audio-user] Terratec DMX6 Fire recording problems & Rosegarden MIDI question

tim hall tech at glastonburymusic.org.uk
Tue Jan 27 22:20:35 EST 2004


On Tuesday 27 January 2004 9:31 pm, RachelAPP wrote:
> Hi
> I am new to Linux and new to this list - a friend of mine set it up last WE
> cause i was fed up with Windows and its capitalist way of working. I have
> Debian 2.4.22 i think (i know it's 2.4 something). It got installed using
> Knoppix then it got upgraded. We tried to upgrade it to 2.6 but some things
> were obviously wrong in the set up as it doesn't boot properly (probably
> something wrong with the graphic settings cause the screen goes all black).
> So i boot to 2.4.

You're best off sticking with the 2.4.22 kernel for many reasons. That's the 
version number for the Linux  kernel rather than the Debian version (3.1 - 
aka 'Sarge' I'd guess)

> I have a Terratec DMX 6 Fire soundcard and Rosegarden 4 and Audacity but my
> problem is i don't seem to be able to record anything. I plugged in my 4
> tracks portastudio into the line input as i used to do and i can hear it on
> my monitors but i can't record anything in Audacity. I have tried to play
> around with the various things in the alsamixer, setting everything to
> Capture and all the levels up and so on, but to no avail.
> Has anyone got any idea why i can't record?

No, it sounds like your soundcard is more-or-less configured. It would help if 
you could generate some useful error messages, Audacity's not the best for 
that. You should only have to have capture enabled on the line-in bit of the 
mixer and have 'line' selected as input on Audacity. If not you have reason 
to suspect your sound set-up. Are you using ALSA?

> I also have a question about Rosegarden4. I have a Evolution MIDI keyboard
> controller, it's a USB device - i don't seem to get any MIDI date in when
> it's plugged via the USB port but i get MIDI data in when i plug it into
> the front MIDI input on my soundcard, which is OK for now (i will look into
> this USB thing when i upgrade to 2.6 properly i guess). However, i cannot
> hear anything - i have set things to "Midi device 1 channel 1" for example
> and then selected a bank and a sound - i know the MIDI data gets in as i
> can see the small U-meter near the track number go up and down but can't
> hear anything. When i go to the set up, it says somewhere "MIDI OK, no
> audio" - what does it mean and is it a problem?

Rosegarden4 doesn't actually make any sound all on its own AFAIK, you have to 
connect it up to a softsynth using Jackd. I use MusE generally, It's much 
quicker to get working with and has softsynths 'built in' - so to speak. 
Sounds like MIDI is configured ok.

> I was used to a few programs under Windows but i am not a master in any of
> them under Windows and i am totally new to the Linux environment so i'm not
> sure whether it is connected to something wrong in my set up or me not
> understanding how the software actually works...

Could easily be a bit of both ... If you have a full Debian system installed 
you'll probably already havea fair amount of documentation on your hard 
drive. Reading is good :-) Collecting useful looking error messages is also 
good practice.

> Any help would be very much appreciated, especially with the audacity
> recording issue as i've done some recordings with a friend and we want to
> mix them now but we are stuck because of this issue!

There are a multiplicity of different ways this can be achieved. Snd & Sweep 
do much the same thing and it's also worth getting familiar with command-line 
tools: typing:
arecord whatever.wav
aplay whatever.wav
into an xterm is probably the most basic way of achieving the object.
If that doesn't work you have set-up problems.


tim hall

More information about the Linux-audio-user mailing list