[linux-audio-user] Re: M-Audio MidiSport 2x2

Peter Clarke pgclarke at beeb.net
Thu Jan 5 06:57:00 EST 2006

Markus Herhoffer <markus at herhoffer.net> wrote:

> I've been using the M-Audio Midisport 2x2 together with
> the Maya 44 USB for a long time and it worked quite well.
> But after an update of ALSA only the Maya 44 works. The
> module 'snd-usb-audio' is loaded properly and the device
> is recognized by the system. I've also put
> 'snd-usb-audio' on the blacklist of hotplug, because
> hotplug makes some real trouble with USB audio devices.

I had exactly the same problem when updating Gentoo 
recently.  Hans Fugal kindly tried to help me on this list 
on 6 Dec 2005, and sent me this informative link:


However, that didn't fix it for me.  Now, I have an ugly 
workaround in place:  a little script that gets run 
by /etc/conf.d/local.start, which contains the following:

#! /bin/bash
modprobe snd-usb-audio
cd /usr/share/usb/midisport
fxload -D /proc/bus/usb/004/003 MidiSportLoader.ihx -I \ 

This works, provided that the MidiSport is always at the 
same USB bus address;  in your case, you will have to 
change the /004/003 to /002/003.

Hope that helps.

I'm interested by your comment "hotplug makes some real 
trouble with USB audio devices".  I'm having trouble 
getting the audio side of my Novation Speedio (a USB audio 
and MIDI interface) to work properly (as per previous posts 
on this list) - could this be related?  If so, what do I do 
to run it without hotplug?

Just one more comment while I'm mailing the list:  if anyone 
uses the Proteus 2000 (a hardware synth), you might be 
interested in having a copy of a spreadsheet I've prepared, 
which has descriptions of all the drums and percussion 
sounds in the ROM it ships with.  Let me know.

Peter C

More information about the Linux-audio-user mailing list