[linux-audio-user] Xi instruments

Carotinho carotinobg at yahoo.it
Tue Jan 10 19:14:33 EST 2006


> I had much the same problem with jpilot, until:
>         #!/usr/bin/env bash
>         #strombrg at blee:~/src/pilot-link/0.12.0-pre4$
> /usr/local/pilot-link-0.12.0-pre4/bin/jpilot #*** glibc detected *** double
> free or corruption (fasttop): 0x081944e0 *** #Aborted
>         #strombrg at blee:~/src/pilot-link/0.12.0-pre4$ export MALLOC_CHECK_=1
>         #strombrg at blee:~/src/pilot-link/0.12.0-pre4$
> /usr/local/pilot-link-0.12.0-pre4/bin/jpilot #malloc: using debugging hooks
>         #removing stale pidfile
>         #*** glibc detected *** free(): invalid pointer: 0x081ef5b0 ***
>         #*** glibc detected *** free(): invalid pointer: 0x081da1c8 ***
>         export MALLOC_CHECK_=1
>         /usr/local/pilot-link-0.12.0-pre4/bin/jpilot "$@"
>         strombrg at blee:~/bin$

I discovered that if I run soundtracker as root, I get no more errors. But the 
malloc problem appears even if I chmod -s the executable, and remove the 
realtime-lsm module... I can't figure out other reasons why it worked up to 
Slack 10.1. Still, I'm not sure to be willing to use it...:)



Yahoo! Mail: gratis 1GB per i messaggi e allegati da 10MB 

More information about the Linux-audio-user mailing list