[LAU] hdspmixer: HwDep ioctl failed. Metering stopped

Mark Knecht markknecht at gmail.com
Mon Feb 23 15:34:20 EST 2009

It seems that Florian has 'inside' information and suggests that this
doesn't matter so I'd not worry about it to much.

If you still want to check it I *think* you run one of RME's firmware
updates and it tells you what is installed before it does the update.
I just tried the version that's on their website and it tells me I'm
hardware revision 104 and programming status is 'not updated'. Watch
out though as the web site has firmware released a few days ago on the
19th and I'm talking about firmware that came with my card years ago.
RME used to give you access to this really old stuff but I'm not
finding the link they used to have to the older firmware so we all
might be out of luck if they won't supply it.

You don't want to run this app unless you have a copy of the one that
takes you back. The banner for this new version gives a very cryptic

HDSP Fut. Rev. 17/55/108/154/207/234

I suspect that those are different firmware revisions for different
products but I really don't know.

AGAIN, BE VERY CAREFUL. (Or ask Florian to drop by...) ;-)

Good luck,

On Mon, Feb 23, 2009 at 11:50 AM, Alex Norman <alex at neisis.net> wrote:
> So, he isn't 100% sure how to check the firmware version.  He is "definitely
> using old firmware" and he thinks it is 011 / 151 as recommended.  Can someone
> tell me exactly how he can check it?  He has access to a windoze boot.
> Below is my conversation with him:
> 11:42 <@     jmej> i installed some drivers in windows - i'm definitely using old firmware - i can't say for sure which version.. but probably
>                   011 / 151
> 11:42 <@     jmej> which seems to be one that's known to work
> 11:42 <@     jmej> the new RME software has firmware revision info in the about tab... the old software does not
> 11:43 <@     jmej> but when i run new software - it tells me to update my firmware (i didn't)
> 11:43 <@     jmej> and when i run the software that goes alon with 011/151 it seems to work fine
> [he's talking about running it in windoze here]
> Thanks,
> Alex
> On  0, Mark Knecht <markknecht at gmail.com> wrote:
>> On Sun, Feb 22, 2009 at 10:44 PM, Florian Faber <faber at faberman.de> wrote:
>> > On Sun, 2009-02-22 at 19:51 -0800, Mark Knecht wrote:
>> >> Please report back what version of firmware your HDSP has. you cannot
>> >> use the more recent versions and may have to downgrade to an earlier
>> >> firmware version to get correct operation. (More or less...)
>> >
>> > That shouldn't result in this error message, but in strange channel
>> > readings in hdspmixer itself.
>> >
>> >
>> > Flo
>> I'm just saying that if RME updated firmware 3 weeks ago and he's the
>> first person that got a card with that on it then there isn't anyway
>> any of us could know what it does for sure.
>> It would be good if he reported what version of firmware had had so we
>> could eliminate that as a potential cause of the problems he's having.
>> It's ost likely not the root cause but it wouldn't hurt to know.
>> - Mark
>> _______________________________________________
>> Linux-audio-user mailing list
>> Linux-audio-user at lists.linuxaudio.org
>> http://lists.linuxaudio.org/mailman/listinfo/linux-audio-user

More information about the Linux-audio-user mailing list