[LAU] debugging conflicts Pulseaudio/Jack

Federico Bruni fedelogy at gmail.com
Sun Jan 20 14:52:29 UTC 2013

Il 20/01/2013 15:03, Federico Bruni ha scritto:
> Finally, I've reset my configuration (only ~/.pulse/default.pa) and
> couldn't reproduce the error.
> Doing more testing...

Ok, I could reproduce the error.
In Qjack I have a default profile and a firewire profile. As long as I 
use the alsa profile, applications using jack and applications using 
PulseAudio work fine together.

The I tried to switch to firewire.
I first noticed that jack was not able to do the switch and kept running 
with alsa (respawn?):
$ ps ax | grep jack
12154 ?        S<Lsl   3:33 /usr/bin/jackd -T -ndefault -dalsa -dhw:0 
-r48000 -p128 -n3

I had to kill the process and start (q)jack again.

Then I stopped jack and tried VLC: no sound. No output device in the 
Audio settings. In this case jack is not respawned:

$ ps ax | grep jack
12917 ?        S      0:00 /bin/sh /usr/bin/qjackctl
12925 ?        S      0:09 /usr/lib/qjackctl/qjackctl.real
13430 pts/3    S+     0:00 grep jack

Are you sure it's a bug in PulseAudio?
Or rather a wrong configuration?


More information about the Linux-audio-user mailing list