[LAU] udev broken?

david gnome at hawaii.rr.com
Thu Apr 12 09:42:44 CEST 2018

On 04/11/2018 09:01 PM, Will Godfrey wrote:
> On Wed, 11 Apr 2018 12:32:38 -1000
> "David W. Jones" <gnome at hawaii.rr.com> wrote:
>> On April 11, 2018 11:20:25 AM HST, jonetsu <jonetsu at teksavvy.com> wrote:
>>> On Wed, 11 Apr 2018 19:14:23 +0100
>>> Will Godfrey <willgodfrey at musically.me.uk> wrote:
>>>> I did an upgrade (debian testing) a couple of weeks ago, and found
>>>> xfce could no longer automout USB sticks and drives (pmount still
>>>> works). On Monday, I decided to do some work on an Arduino, and it
>>>> seems that also can no longer recognise boards plugged in via usb.
>>> Just curious, what would be the need to upgrade to Debian *testing* in
>>> the first place ?
>> I run Debian Testing, get more current software that way. But I don't think Will meant he upgraded *to* Debian Testing. I think he did just like I did: updated his existing installation.
> Exactly!


>> Sorry, Will, but I did same upgrade and don't have any problem with USB drives and such. I don't have an Arduino, so can't check that.
> It seems there are two separate issues that just happened to appear at the same
> time.
> The Arduino one I solved by getting the package direct from the Arduino website
> (it is completely self contained).


> The automount one is puzzling. Initially I thought it was a permissions issue of
> some sort, but couldn't find any that have changed. Further investigation
> suggests this is a glib problem :(

I just checked that here at home. Inserted a USB stick drive, it didn't 
automount. I fired up gparted and discovered that the drive had somehow 
acquired a mangled partition table and lacked partitions. (I think I 
tried to update a Live Linux + persistence setup a friend had put on it 
for me several years ago.)

Rewrote a partition table and formatted it as EXT4 and it automounted 
just fine. When I have more energy and time, I'm going to sort out how 
to put AVLinux 2018 on it. May have to do this from a VM running the 
AVLinux ISO, will consult their manual.

Which version of glib do you have? I have no idea how to tell.

David W. Jones
gnome at hawaii.rr.com
authenticity, honesty, community

More information about the Linux-audio-user mailing list