[LAU] sound with Scarlett 3rd Gen device?

Iain Mott mott at escuta.org
Thu Jan 30 13:18:11 CET 2020

and another observation:

It occurred to me to boot into Windows with the Scarlett attached and 
then pull out the USB before shutting down Windows. The Scarlett seems 
to hold its levels and the LEDs continue to respond to mic input once 
detached. I tried then booting into Linux, the levels hold on the 
Scarlett until the USB is plugged back in again whereupon the input 
level falls to zero and/or becomes unresponsive. Perhaps it's some sort 
of speaker protection thing.... Looks like the device consults fader 
values stored on the computer on USB-connect, but with no such values 
available, zeros the device. Just guessing.

Em 30/01/2020 08:38, Iain Mott escreveu:
> Adding to that:
> If in Windows, I plug in a mic into channel 1 and turn up the input 
> gain, the input LEDs respond as they should to incoming sound. I can 
> also in the Focusrite Control sodtware, map the input directly to the 
> monitor so that I I can hear it in the headphones. If I then reboot 
> the laptop, the LED and routing continue to function until the machine 
> loads the Grub system boot page, whereupon the LED stops functioning 
> and the monitoring of the mic also stops. The mic channel remains 
> unresponsive when Linux is booted. This is a bit worrying as I had 
> read for earlier generations that the control routing set in Windows 
> is remembered by the Scarlett once in Linux (and presumably after 
> switching the box on and off).
> The F6 button in alsamixer shows "Scarlett 18i20 USB", however once 
> selected, for capture/input, it says something to the effect of: this 
> device has no input/capture controller. For reproduction/playback it 
> lists only S/PDIF but with no fade controler.
> Hope someone can help!
> Iain
> Em 30/01/2020 06:24, Iain Mott escreveu:
>> Dear Linux audio people,
>> I have a Scarlett 18i20 3rd Gen interface which I'm trying to use on 
>> a recent Samsung laptop with Ubuntu 19.04.
>> The 3rd gen devices are apparently shipped in non-functional "MSD" 
>> mode, so I registered and activated the device using Windows 10 
>> following the instructions on the Focusrite website. Tested it there 
>> with Ableton Live Lite (provided via registration of the device) and 
>> also Ardour. It works fine. To get it to work on Ardour it was 
>> necessary to use the ASIO driver in the Ardour audio configuration. I 
>> had removed ASIO4ALL before installing the Focusrite/Scarlett 
>> software as suggested, so perhaps this driver came with Focusrite 
>> install.
>> Now with the device apparently configured and the routing done in 
>> Windows using the Focusrite Control software (i thinks that's the 
>> name, I had selected output channels 1 and 2 to connect with the 
>> monitors/headphone jack), I returned to Linux. The Scarlett device is 
>> detected by lsusb, qjackctl and pavucontrol. Jack runs with no errors 
>> when the Scarlett is selected as the i/o device and all the correct 
>> channels appear in the Connect window. No sound however is heard 
>> through the phone jack, nor if i plug the phones directly in to the 
>> output jacks at the back. I tested using VLC configured for Jack 
>> output and also with pd -jack.
>> With jack turned off and with VLC audio out set to pulsaudio, I set 
>> the Scarlett 18i20 as the preferred device in pavucontrol. With VLC 
>> playing the output VU meter for the Scarlett is active in pavucontrol 
>> but there is still no sound coming out of the device itself.
>> Has anyone managed to get a 3rd generation Scarlett to work on Linux? 
>> Can anyone suggest please what I can do?
>> Thanks!
>> Iain
>> PS. i did see an unresolved thread on this list last year about a 3rd 
>> gen Scarlett. I'll send a message to the author to see if the problem 
>> was fixed.
>> _______________________________________________
>> Linux-audio-user mailing list
>> Linux-audio-user at lists.linuxaudio.org
>> https://lists.linuxaudio.org/listinfo/linux-audio-user
> _______________________________________________
> Linux-audio-user mailing list
> Linux-audio-user at lists.linuxaudio.org
> https://lists.linuxaudio.org/listinfo/linux-audio-user

More information about the Linux-audio-user mailing list