Fernando Pablo Lopez-Lezcano writes:
I would say (as in Kjetil's patch):
echo "0">/proc/sys/kernel/setschedandmlock
--> normal behavior
I suggest picking a clearer name, like /proc/sys/kernel/realtime.
I agree, sounds better. It does not say what it does as the original
++votes
echo
"1">/proc/sys/kernel/setschedandmlock
--> access to mlock and SCHED_FIFO and:
echo "xx">/proc/sys/kernel/setschedandmlockgroup
--> only users in group "xx" can access privileges
default for "xx" would be "0" which means everybody
Here, I suggest something like /proc/sys/kernel/rtgroup.
Maybe "realtimegroup"? I kind of like the same "root" for both
options,
it groups them together.
++votes
Also, 0 is a
valid group ID, `root', which might be a reasonable
choice if groups like `audio' and `realtime' are undefined. How about
using -1, instead? Or, maybe `nogroup' (65534 on my system).
Yes, probably "nogroup" is the best option. I think it is "nobody" in
my
system - so we cannot rely on the same name either... yuck...
i think it would be safer to use 0, which means root (and is kinda
senseless) as default. granting realtime privileges to everybody is
exactly what we don't want... and it's likely to do that by accident
when having this as a default.
or did i miss the meaning of "nogroup"? i ever thought that this is
the group for users which are granted really NOTHING...
martin