Chris Cannam wrote:
On Wednesday 26 Jul 2006 11:12, Florian Paul
Schmidt wrote:
Well, it is very thin though. Which is not a bad
thing at all. One could
make ue of an arbitrary amount of more advanced C++ features if desired
though (i.e. templates parametrized with the type you want to read for
example, or operator<< and operator>> for reading and writing, etc.)
operator<< and >>... ugh.
Yeah I really gotta agree here. Overloading the left and right
shift operators has got to the thing I find most distasteful
about C++.
I think if your class is named LikeThis, then
your method should be named
likeThat (Java-style). If your method is named like_this, then your class
should be named like_that (STL-style). Either is fine, but don't mix your
dialects.
Ok, "don't mix dialects" is a good tip. Most of the proposed methods
for the Sndfile class have single word names so Java style might be
the best option.
Mmm. For what it's worth, I write mostly C++
but have no problem
with using the libsndfile C API.
Most people who really know C++ know enough to be comfortable
with pure C. I'm pretty sure you fall into this category.
However, I do get emails from some of the more clueless Windiots
complaining that libsndfile is written in old-fashioned C instead
of nice shiny modern C++. IMNSHO these people should not be allowed
anywhere near a language as complex, subtle, and unforgiving as
C++ (or for that matter as unforgiving as C).
Erik
--
+-----------------------------------------------------------+
Erik de Castro Lopo
+-----------------------------------------------------------+
"I consider C++ the most significant technical hazard to the survival
of your project and do so without apologies." -- Alistair Cockburn
Are you sure these people should be let near a computer, less alone a
complex, subtle and unforgiving language? ;) I still love your sig
messages.... ;)
Loki
--
"If once a man indulges himself in murder, very soon he comes to think
little of robbing; and from robbing he next comes to drinking and
Sabbath-breaking, and from that to incivility and procrastination."
-- Thomas De Quincey (1785 - 1859)