Ryan, Dave-
A couple people have reported a problem compiling FreeWheeling. Here's the error:
fweelin_videoio.cc: In member function `void
VideoIO::DrawLoop(RecordPlayer*, int, SDL_Surface*, SDL_Surface*,
SDL_Color*, float, FloConfig*, FloLayoutElement*, CircularMap*,
int, int, float, nframes_t*, nframes_t*, float*)':
fweelin_videoio.cc:993: `filledpieRGBA' undeclared (first use this
function) fweelin_videoio.cc:993: (Each undeclared identifier is
reported only once for each function it appears in.)
fweelin_videoio.cc: In member function `void
VideoIO::video_event_loop()': fweelin_videoio.cc:1090: warning:
unused variable `const SDL_Color infobarclr' make[1]: ***
[fweelin_videoio.o] Error 1 make[1]: Leaving directory
`/home/dlphilp/fweelin-0.5pre1/src' make: *** [all-recursive] Error 1
Originally I reported that 'filledpieRGBA' is in SDL_gfxPrimitives.h. But I am
using Debian version 2.0.9-4. Trying the latest version, 2.0.13-- I get the
same error you are getting. The problem is a change in naming convention
between the two versions.
If you're having this problem, go into 'src/fweelin_videoio.cc' and replace
all occurrences of 'filledpieRGBA' with 'filledPieRGBA'. That should do
it.
I'll put a check into a subsequent release.
All the Best,
JP Mercury